Javafree
Página Inicial do Fórum > Banco de Dados - JDBC / SQL

conexao Mysql - erro ssl



Criar novo tópico   Responder tópico


  1. luckpr
    Posts:1


    Comment Arrow

    Publicado em: 14/04/2016 10:51:33

    PROCUREI POR POSTS PARECIDOS E ACHEI SOMENTE 1 SOBRE O PROBLEMA MAS EM LINUX, NO MEU CASO É WINDOWS10;

    Minha conexao com mysql parece ter sucesso mas estou com o seguinte erro:

    WARN: Establishing SSL connection without server's identity verification is not recommended. According to MySQL 5.5.45+, 5.6.26+ and 5.7.6+ requirements SSL connection must be established by default if explicit option isn't set. For compliance with existing applications not using SSL the verifyServerCertificate property is set to 'false'. You need either to explicitly disable SSL by setting useSSL=false, or set useSSL=true and provide truststore for server certificate verification.

    Neste codigo:

    package controle;

    import java.sql.Connection;
    import java.sql.DriverManager;
    import java.sql.SQLException;
    import java.sql.*;

    public class Database {

    Connection con = null;
    public Database()
    {
    try{
    String url = "jdbc:mysql://127.0.0.1:3306/projetoclinica";
    String user = "root";
    String password = "pass";

    Class dbDriver = Class.forName("com.mysql.jdbc.Driver";
    con = DriverManager.getConnection(url, user, password);
    }
    catch (Exception ex)
    {
    ex.printStackTrace();
    }
    finally
    {
    if (con != null)
    {
    try
    {
    con.close();
    }
    catch (Exception e){}
    }
    }

    }
    }

    tentei mudar para :

    String url = "jdbc:mysql://127.0.0.1:3306/projetoclinica"+
    "?verifyServerCertificate=false"+
    "&useSSL=true"+
    "&requireSSL=true";

    mas deu um erro pior ainda, parece que nao consegue encontrar o ssl,

    dei um show variables no MySQL>
    mas aparece o ssl e openssl 'disable'

    como habilitar ele?

    obrigado DESDE JA A TODOS!



  1. mag0966
    Posts:1


    Comment Arrow

    Publicado em: 23/05/2016 18:17:31

    Eu coloquei o useSSL na url, assim parou de dar o WARN.

    Connection con = DriverManager.getConnection("jdbc:mysql://localhost:3306/INTtech?useSSL=false","root","root"



  1. Relacionados